
Particle Detector and Tracker 
An ImageJ Plugin for particles detection and tracking from digital videos. 
The plugin implements the feature point detection and tracking algorithm as described in: 
 
I. F. Sbalzarini and P. Koumoutsakos. Feature point tracking and trajectory analysis for video 
imaging in cell biology. J. Struct. Biol., 151(2): 182–195, 2005. 
 
Any publications that made use of this plugin should cite the above reference. This helps to 
ensure the financial support of our project at ETH and will enable us to provide further 
updates and support. Thanks for your help! 
 
 
General Description 
This plugin presents an easy-to-use, computationally efficient, two-dimensional, feature point-
tracking tool for the automated detection and analysis of particle trajectories as recorded by 
video imaging in cell biology.  
The tracking process requires no apriori mathematical modelling of the motion, it is self-
initialising, it discriminates spurious detections, and it can handle temporary occlusion as well 
as particle appearance and disappearance from the image region.  
The plugin is well suited for video imaging in cell biology relying on low-intensity fluorescence 
microscopy. 
It allows the user to visualize and analyse the detected particles and found trajectories in 
various ways: 

¾ Preview and save detected particles for separate analysis 
¾ Global non progressive view on all trajectories 
¾ Focused progressive view on individually selected trajectory 
¾ Focused progressive view on trajectories in an area of interest 

It also allows the user to find trajectories from uploaded particles position and information text 
files and then to plot particles parameters vs. time – along a trajectory 
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Installation and first steps 
This Plugin requires ImageJ (v. 1.36b or later) to be installed on your machine.  
You can check the currently installed version of ImageJ by starting ImageJ and selecting 
‘About ImageJ…’ from the Help menu. 
 
If ImageJ is not installed and/or if you don’t know how to basically use it please go to 
http://rsb.info.nih.gov/ij/ for download information and user manual. 
ImageJ requires large amounts of memory especially when working with long movies/ large 
files. To make more than the default allocated size of memory available to ImageJ, go to the 
installation section of that site. This is highly recommended! 
More useful information can be found at http://www.uhnresearch.ca/facilities/wcif/imagej/ 
 
The plugin should work on every platform ImageJ works on but has been tested mainly on 
Windows XP and MacOS X. 
Once ImageJ is installed it is very simple to add the plugin: 
 

• Copy the ParticleTracker_.jar file into the plugins folder and restart ImageJ. The 
plugin will appear under the Plugins -> Particle Detector & Tracker menu the next 
time you start ImageJ. 

 
 
File opening – Normal mode 
Before the plugin can be started you must open an image sequence or a movie in ImageJ. 

• For opening an image sequence use the Import\Image Sequence... option from the 
File menu. 

• For opening a movie file use the Open option form the File menu. 
• See the “Input files and formats” section for information about image files formats 

 
More about opening and importing files can be found here: 
http://rsb.info.nih.gov/ij/docs/menus/file.html 
 
File opening  - Text files Mode 
You can also use the plugin in the Text Files Mode: 
If you have already analysed a movie with this plugin or any other tool and you have the 
particles position saved for each frame then you can use this mode to find trajectories. 
In this mode you don’t need an image sequence or movie to detect feature points (particles) 
but instead you provide text files with the particles positions in each frame. 
You should have a file for each frame in the original movie.  
The expected format of the input file is described at “Particles information (Frame) file format” 
section below. All the files should be in the same folder without any other files.  
Start the plugin in this mode by selecting it from the appropriate submenu in the Plugins menu 
without opening a movie or file sequence before. 
You will be asked to confirm the use of the Text files Mode and then select the folder of the 
input text files. To the select the folder just click on one of the files in the folder and Open.  
Next, you will be asked about the information provided in the text files on top of the particles 
position. If the 3rd and 4th columns in the input files contain the intensity moments of order 0 
and 2, for the particles, check to appropriate checkbox. 
For the next steps, go to the Plugin start -> Particle Linking part of this manual.  
 
 
 

http://rsb.info.nih.gov/ij/
http://www.uhnresearch.ca/facilities/wcif/imagej/
http://rsb.info.nih.gov/ij/docs/menus/file.html


Plugin start 
Now, that the movie is open you can start the plugin by selecting ParticleTracker from the 
Plugins -> Particle Detector & Tracker menu.  
If you want only to detect particles without the tracking part use can select ParticleDetector 
from the same menu. 
After starting the plugin, a dialog screen is displayed.  
The dialog has two parts “Particle Detection” and “Particle Linking”  
 
Particle Detection 
This part of the dialog allows you to  

• Adjust parameters relevant to the particle detection (feature point detection) part of 
the algorithm  

• Preview the detected particles in each frame according to the parameters. This 
options offers assistance in choosing good values for the parameters. 

• Save the detected particles according to the parameters for all frames 
 
 
The parameters relevant for detection are: 

• Radius: Approximate radius of the particles in the images in units of pixels. The value 
should be slightly larger than the visible particle radius, but smaller than the smallest 
inter-particle separation.  

• Cutoff: The score cut-off for the non-particle discrimination 
• Percentile: The percentile (r) that determines which bright pixels are accepted as 

Particles. All local maxima in the upper rth percentile of the image intensity 
distribution are considered candidate Particles. Unit: percent (%) 

 
Preview the detected particles: 
Clicking on the Preview Detected button will circle the detected particles in the current frame 
according to the parameters currently set.  
To view the detected particles in other frames use the slider placed under the Preview 
Detected button. 
You can adjust the parameters and check how it affects the detection by clicking again on 
Preview Detected.  

 
Save the detected particles: 
You can save the detected particles to files (a file for each frame) by clicking the Save 
Particles button. This will open a Save Files dialog where you need to select the target folder 
for the saved files and enter the prefix of the files name. 
The program will create a file for each frame in the movie with the name 
prefix_frameNumber.txt (e.g. frame_0.txt, frame_23.txt).  
The default file name prefix is `frame`. 
The format of the saved files is compatible with the Text files Mode and is described under 
“Particles information (Frame) file format”. 
 
Particle Linking 
This part of the dialog allows you to 

• Adjust parameters relevant to the particle linking (trajectories generation) part of the 
algorithm 

 
The parameters relevant for linking are: 

• Displacement: The maximum number of pixels a particle is allowed to move between 
two succeeding frames. 

• Link Range: The number of subsequent frames that is taken into account to 
determine the optimal correspondence matching. 

 
 
After setting all parameters, tracking can be started by clicking the OK button in the dialog 
window.  You can also stop here by clicking the Cancel button. 
Progress info will be displayed in the main ImageJ Status Bar. 
 



Results window and options 
After completing the particle tracking, the result window with 3 sections will be displayed. 

• Configuration panel (top) – displays the user defined parameters (e.g. radius) and 
other general information. 

• Verbose information panel (middle) – displays detailed information according to user 
requests. Information displayed in this panel can be exported to any text editor by 
mouse right click -> select all, mouse right click -> copy. 

• Display options panel (bottom) – allows the user to inspect the tracking results and 
visualize them in a number of ways. 

 
Display options panel 
This panel is divided to 3 sections. 
 
All Trajectories – allows you to inspect and save results (about all trajectories) from Particle 
detection to trajectories generation 

• Visualize All Trajectories – opens a new window that visualizes all the trajectories and 
the original movie frames in an overlay.  
¾ The trajectories are displayed at their full length (non progressive view). 
¾ A red section in a trajectory indicates a ‘gap’ in it. This is a part in the 

trajectory that was interpolated by the algorithm to handle occlusion, exit and 
entry of the particle along a trajectory.  

¾ This view cannot be saved with the trajectories layer. 
¾ This view’s main purpose is for overview, trajectory and area selection (see 

next 2 sections of this panel) 
¾ All the standard ImageJ options for stack window (zoom, drag, etc…) are 

also available  
• Save Full Report – saves a verbose report of the results including the intermediate 

phases of the algorithm 
• Display Full Report – displays a verbose report of the results including the 

intermediate phases of the algorithm 
 
The format of the result file and display is described at the “Full report format” section below 
 
After opening the visualization window (Visualize All Trajectories) you can 

• Select a specific trajectory for analysis by clicking with the mouse on it. A rectangular 
area surrounding the trajectory will appear and the serial number of it will appear in 
the Trajectory section – the options under this section will now be available  

• Select a region of interest by clicking and dragging the mouse. A rectangular area 
surrounding the selected area will be displayed. The options under the Area section 
will now be available. 

• Filter the trajectories to visualize by clicking the Filter button at the bottom left side of 
the visualization window. Enter the minimum length (in frames) for trajectories to be 
displayed (default is to display all), trajectories below that length will be excluded. 

 
Trajectory – allows you (after selecting a trajectory from the visualization window) to inspect 
and visualize 1 selected trajectory 

• Selected Trajectory Info – displays the selected trajectory information (in the standard 
format as described) on the verbose information panel.  

• Focus on Selected Trajectory – opens a new window with a progressive focused 
view of the selected trajectory and the original movie frames. 
¾ In this view the trajectory tail is animated and grows with time 
¾ This movie can be saved as any format supported by ImageJ using the 

options under the File menu. 
¾ A red section in a trajectory indicates a ‘gap’ in it. This is a part in the 

trajectory that was interpolated by the algorithm to handle occlusion, exit and 
entry of the particle along a trajectory. 

¾ The length of the trajectory tail (in frames) can be modified through the View 
Preferences menu at the top of the results window. This is usually helpful 
when a trajectory is long and crosses itself – by reducing the length of the 
tail, you can make better sense of the track. 



¾ The magnification factor can be modified through the View Preferences menu 
at the top of the results window. 

• Plot (only available for Text files Mode!) – plots one of the given particle parameters 
verses frames, its shows the changes of this parameter along the selected trajectory.  
¾ Select the parameter number (according to the position it was given in the 

input file) to plot and click OK.  
¾ The X-axis is the frame number and Y is the parameter value.  
¾ The plotted information can be displayed (List), saved (Save) or copied to the 

clipboard (Copy) as a table of X and Y to be used in external plotting tools. 
¾ The plot image can be saved as an image using the ImageJ Save options 

under the File menu. 
 
Area - allows you (after selecting a region of interest on the visualization window) to inspect 
and visualize the trajectories in the selected area 
 

• Trajectories in Area Info – displays the information of all trajectories in the selected 
area on the verbose information panel.  

• Focus on Area – opens a new window with a progressive focused view of the 
selected area, the trajectories in it and the original movie frames. 
¾ In this view the trajectory tail is animated and grows with time 
¾ This movie can be saved as any format supported by ImageJ using the 

options under the File menu. 
¾ A red section in a trajectory indicates a ‘gap’ in it. This is a part in the 

trajectory that was interpolated by the algorithm to handle occlusion, exit and 
entry of particle along a trajectory. 

¾ The length of the trajectory tail can be modified through the View Preferences 
menu at the top of the results window. This is usually helpful when a 
trajectory is long and crosses it self – by reducing the length of the tail, the 
user can make better sense of track. 

¾ The magnification factor can be modified through the View Preferences menu 
at the top of the results window. 

 
 
Re-linking of the detected particles 
After viewing the generated trajectories you may want to use different parameters for the 
linking algorithm. You can re-link the detected particles with different link range and percentile 
parameters then initially selected through the Relink Particles menu at the top of the results 
window. After re linking the particles, you can view the new generated trajectories with all the 
available options. The originally generated trajectories will not be available unless you re-link 
the particles with the original parameters. 



Input files and formats 
Image and Movie files 
The plugin normal mode works on a sequence of image files or a single movie file. It should 
work with any format that ImageJ works with but the recommended files formats are Tiff 
images or mpeg\ AVI movies all of 16-bit grayscale.  
For some files formats (e.g. AVI) you must first install the necessary plugins. 

More about plugins for other movie formats can be found here: 
http://rsb.info.nih.gov/ij/plugins/avi-reader.html 
http://rsb.info.nih.gov/ij/plugins/jmf.html 
http://rsb.info.nih.gov/ij/plugins/movie-opener.html 
PC users can use the free VirtualDub program to uncompress Tiff\ AVI files 
http://virtualdub.org/ 
 

When importing image sequence you have an option to convert it to 8-bit grayscale. This is 
highly recommended if your original sequence is RGB1 due to high memory consumption. 
When loading a RGB movie this option will be given when starting the plugin. 
 
Trajectory information format (Saved to file and displayed on screen) 
A trajectory will have at least 2 rows, each row representing a frame in this trajectory and 
holding the information about the particle related to this trajectory in that frame. 
 
The first column indicates the frame number, starting at 0 for each trajectory.  
The second and third columns contain the x- and y-coordinates of the particle, respectively. 
The x-axis points top-down and the y-axis is oriented left-right in the image plane.  
The 4th and 5th columns contain the intensity moments of order 0 and 2, respectively (m0, 
m2).  
The 6th column contains the non-particle discrimination score.  
When more then one trajectory is displayed, blank line separates each individual trajectory.  
 
Example: 
%% Trajectory 9 
0 12.391691 12.768608 5.112213 2.500295 104.655037 
1 12.454874 12.930519 5.194430 2.587620 60.088043 
2 12.611449 12.951291 4.248880 2.535324 37.688339 
3 12.775870 13.275779 4.603161 2.535339 56.550217 
4 12.349064 13.763223 4.783348 2.571657 81.464935 
 
Particles information (Frame) file format  
Used when saving detected particles and assumed when loading particles position from file 
 
Each file represents a frame. 
First line starts with the word ‘frame’ followed by the frame number this file represents. 
Each line after the first represent a detected particle with 2 columns at least, separated by 
one or more space characters. The first and second columns contain the x- and y-coordinates 
of the particle, respectively. The x-axis points top-down and the y-axis is oriented left-right in 
the image plane. When saving the detected particles to file – the 3rd and 4th columns contain 
the intensity moments of order 0 and 2, respectively (m0, m2).   
When loading particles from file, these 3rd and 4th columns are optional – you need to indicate 
whether this information is present when loading particles information from file (Text files 
mode). 
In Text Files Mode you can also add more columns of information (with or without the m0 and 
m2) about each particles as long as it’s the same number for all particles in all frames number  
 
Example of saved particles file output and particle input file formats: 
frame 0 
12.391691 12.768608 5.1122127 2.500295 
22.656208 12.654181 5.1463113 2.565635 

                                                 
1 RGB images are converted to grayscale using the formula gray=0.299red+0.587green+0.114blue or the formula 
gray=(red+green+blue)/3 if "Unweighted RGB to Grayscale Conversion" is checked in Edit/Options/Conversions. 

http://rsb.info.nih.gov/ij/plugins/avi-reader.html
http://rsb.info.nih.gov/ij/plugins/jmf.html
http://rsb.info.nih.gov/ij/plugins/movie-opener.html
http://virtualdub.org/


32.586590 12.600200 5.4279966 2.756498 
42.388741 12.633677 5.046486 2.637388 
 
Full report format (Output file and display) 
 
The header contains general information about the tracking job such as the used parameter 
settings and global input information, for example:  
 
% Configuration: 
%  Kernel radius : 3 
%  Cutoff radius : 3.0 
%  Percentile    : 0.0090 
%  Displacement  : 10.0 
%  Linkrange     : 2 
%  Displacement : 10.0 
% Frames information: 
%  Width : 118 pixel 
%  Height: 118 pixel 
%  Global minimum: 0.0 
%  Global maximum: 62.0 
 
Next part contains the particle information per frame: original detected position of the particle, 
the refined position and particles left after non-particle discrimination. 
 
% Frame 0: 
% 3 particles found 
% Detected particle positions: 
%  12.000000 13.000000 
%  23.000000 13.000000 
%  33.000000 13.000000 
% Particles after position refinement: 
%  12.391691 12.768608 
%  22.656208 12.654181 
%  32.586590 12.600200 
% Particles after non-particle discrimination (2 particles): 
%  12.391691 12.768608 
%  32.586590 12.600200 
 
Next part contains particle linking information per frame, displays for each particle in a frame 
the particles it is linked to. 
 
% Frame 0 
% Particle 0 (12.391691, 12.768608) 
%  linked to particle 0 in frame 1 
%  linked to particle 0 in frame 2 
% Particle 1 (22.656208, 12.654181) 
%  linked to particle 1 in frame 1 
%  linked to particle 1 in frame 2 
 
Last part contains the final found trajectories information in the trajectory format described 
above. 
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